Just tested this on a Sage 100 ERP 4.10 standard to 2013 with Hightower TB and TK (highly suspicious that this is the problem but unsurprisingly they've never seen it).
1. Reinitialized SY_ClassEnhancement file on the 4.10 system
2. Migrate
3. ""Prepare failed with the following error A/L is invalid""
Pulling a case with Sage
Once I get the ""Prepare failed with the following error..."" the 2013 system is hosed and I need to restore from a backup or reinstall
Sage suggested renaming the HT program file on my 2013 install to OLDHT (I might use PIECEOF****HT), remigrate, then name the folder back to HT. Still testing and will update.
Renamed the HT to OLDHT in the 2013 folder -- however now upon startup I get ""Unable to create a session object. The workstation may have been corrupted. Reinstall workstation setup"". This is a direct result of renaming HT to OLDHT because when I name it back (no other changes) the problem goes away.
Note: I'm wondering whether Sage meant HT on the 4.10 folder. Update: Tried renaming HT in the v4.10 folder and same results of A/L is invalid.
Note: Nothing below worked either - I'm including it just because it'll provide some insight to the things Sage suggested to be tried.
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Spend another 30 minutes fiddling with uninstall/reinstall workstation setup - no luck. I still get the ""workstation may have been corrupted"" so long as HT is renamed. If I rename the OLDHT back to HT and try to startup workstation it works perfectly.
Back on the Sage que for support.
After this error pops up you cannot get into 2013 and may see a myriad of messages including:
Error 47 - Sy_Launcher_ui.pvc Line 1955
Sage now suggesting using *UFAR as follows:
Error: Prepared failed with the following error: The D/M is invalid
Article
Products
Sage 100 ERP 2014
Description
""Prepared failed with the following error: The x/x is invalid"" when migrating to Sage 100 ERP 2014
Cause
Invalid records in SY_Griddefinition.m4t
Resolution
Run UFAR on SY_Gridefinition.m4t from the Source installation
1. Make a backup of ...MAS90\MAS_System\SY_GridDefinition.M4T file
2. Open ...\MAS90\Home\pvxwin32.exe
3. Select OK to Providex message
4. Type: run ""*UFAR
5. Press Enter
6. Type: <driveletter>:\....MAS90\MAS_System\SY_GridDefinition.M4T
(i.e. C:\Sage\Sage 100 ERP\MAS90\MAS_System\Sy_Griddefinition.m4t)
7. Follow the wizard
How to use the *UFAR utility to rebuild files
Article
Products
Sage 100 ERP
Description
How to use the *UFAR utility to rebuild Sage 100 ERP files; how to run UFAR
Disclaimer
Backup Warning
Use caution when working with the below product functionality. Always create a backup of your data before proceeding with advanced solutions. If necessary, seek the assistance of a qualified Sage Business Partner, network administrator, or Sage Customer Support Analyst.
Resolution
Note: For most files, you should use the Rebuild Key Files utility. The *UFAR utility is reserved for instances where the regular rebuild process does not resolve the error or is not recovering records, due to more severe file and data corruption.
Warning: The *UFAR process does not print a list of records that are stripped from the file. It will not be possible to determine what records were lost. UFAR is not generally recommended. Another alternative may be to restore the file from backup or replace with a new file. You can also run the *UFAC utility on a file beforehand to get a list of potentially bad records. (For more information on *UFAC and Rebuild Key Files, see the Related Resources section below.)
1. Make a backup of the file to be repaired.
(Suggestion: Copy the corrupted file into the root of the C:\ drive, then use this file to run the utility on. Once the process is complete, place it the file back by renaming the original file first, then pasting the new one in its place.)
2. Run the *UFAR utility (either of two methods):
1. Via Windows Explorer, navigate to the ""..\MAS90\HOME"" directory where Sage 100 ERP is installed
2. Right-click the Pvxwin32.exe file
3. Select ""Run as Administrator""
4. Click OK at the ProvideX:Initialization
5. In the ProvideX window, enter the following command at the prompt and press the Enter key:
RUN ""*UFAR""
3. Enter the name of the file to be repaired at the 'Name of Keyed/Direct file' field, with the full path to that file and press the Enter key.
(Example: If you followed the suggestion in Step 1, and corrupted file was GL_DetailPosting.m4t, then the path would be C:\GL_DetailPosting.m4t)
4. The next screen prompts for the name of the backup file (e.g. GL_DetailPosting.B00). Make a note of 'Current # records'. Accept the default and press Enter.
5. The next screen prompts for 'Recover to Highest Active Index or Physical End of Record'. 'Active Index' is usually the correct choice. Press Enter.
6. On the next prompt, ""'Is this correct for ALL records in this file?"", select 'D - Wrong' and press Enter. Note: D = 'Keys contain only printable characters'.
7. You will get the same prompt from Step 8 again without the D selection. Select 'E - Wrong' and press 'Enter'. Note: E = 'Data contains only printable characters'
8. The same screen repeats without 'D' or 'E'. Select 'Yes'.
9. UFAR will then repair the file. The next screen reads ""Recovered nnn records. Clear and reload original file?"". Compare the number of records recovered with 'Current number of records' noted earlier. Select 'Yes'.
10. Verify that a backup has been made in step 1. Then reply 'Yes' to 'File xxxxxx has been repaired successfully, Erase temporary file xxxxx.b00?'.
11. Type 'BYE' at the PVX ( > ) prompt to return to the 'Command' prompt.
12. If you followed the suggestion on step #1, replace this new file from the C:\ drive to its original location. Make sure to rename the original file (e.g. GL_DetailPosting.old), then place the new one in its place.