Sage 100

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  • 1.  SPS/Paya - "The credit card transaction request to Sage Exchange cannot be processed"

    Posted 05-05-2020 17:40
    For those who use SPS/Paya, has anyone been getting support calls for the message "The credit card transaction request to Sage Exchange cannot be processed."?  I've had 4 or 5 customers start support tickets for this very error message.  They're dead in the water and can't process any CC payments, view/edit a card, etc.  It's apparently starting out of nowhere for the customers, and I don't think a windows update was involved.

    The initial fix was to go to ...\MAS90\wksetup\Prerequisites\SageExchange\Setup.exe, which installs Module SDK, but what worked for one customer is now not working for others.  For one customer, a domain/local admin installed it, but it wasn't until I did a reinstall under the user with non-local admin permissions for it to end up working.  For another customer, none of these solutions worked.

    Wondering if anyone else is seeing this issue all of the sudden, and what you've done to resolve it.  Thanks,

    Chris

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    Chris Love
    Accounting Systems, Inc. (ASI)
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  • 2.  RE: SPS/Paya - "The credit card transaction request to Sage Exchange cannot be processed"

    Posted 05-05-2020 21:34
    Not yet.

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    Wayne Schulz - Schulz Consulting - 860-516-8990
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  • 3.  RE: SPS/Paya - "The credit card transaction request to Sage Exchange cannot be processed"

    Posted 05-06-2020 07:49
    If its a known Paya issue, they will post it on their site so you will know its a system-wide issue or something they are working on. If its not there, its most likely not them or possibly it hasn't been reported yet.  I usually head here first if I start getting calls/tickets.
    https://support.paya.com/
    Maintenance & Service Interruption Alerts


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    Dana Young
    Lehman Wesley & Associates
    Lansing MI
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  • 4.  RE: SPS/Paya - "The credit card transaction request to Sage Exchange cannot be processed"

    Posted 05-06-2020 08:24
    Below is the article from Paya Support. I do remember for one customer that installing Module SDK  didn't work for, the Sage Service (they're on Sage 100 Premium) is running under the Local System Account, and I told the IT guy it shouldn't be running that way. It was running as an application and he turned it off there under a local admin account because they wanted to get rid of the windows user account.  That will be the first thing I tell him to do. 

    I know the one I did a reinstall of is also running Sage 100 Premium and the host is running as an application under a local admin account. But that was also only an issue for one user, whereas this other is for everyone. 

    Error Message "The credit card transaction request to Sage Exchange cannot be processed" in Sage 100 (Advanced and Premium)"

    Description

    Error: "The credit card transaction request to Sage Exchange cannot be processed" on Sage 100 Advanced and Premium 

    Resolution

    Disclaimer:

    Network Warning

    This solution requires advanced knowledge of your network. Contact your system administrator for assistance. Modifying Windows security incorrectly can severely affect system operations. Sage is not responsible for operation issues caused by incorrectly modifying your Windows security. Always create a backup of your data before proceeding with advanced solutions.

    Operating System Warning
       This solution requires advanced knowledge of your computer's operating system. Contact your system    administrator for assistance. Modifying your Windows Registry incorrectly can severely affect system operations. Sage is not responsible for operation issues caused by incorrectly modifying your Windows Registry. Always create a backup of your data before proceeding with advanced solutions.
    Cause:
    Possible cause:
    • Sage 100 ERP Service is running under the Local System Account
    • The Account running the Sage 100 ERP Service was not the account that installed Sage Exchange on the server.
    Module SDK is missing in add\remove programs (XP) or Programs and Features (windows Vista or newer) from the source PC.
    Resolution
    • Do not use the Local System Account to run the Sage 100 Advanced / Premium Service
    • Install Sage Exchange using the account running the Sage 100 ERP Service on the Server
    1.     Log onto the server as the account running the Sage 100 ERP Service
    2.     Open www.SageExchange.com/Install 
    3.     Click Next to proceed to Sage End User License Agreement
    4.     Click Install 
    5.     Launch Sage 100 ERP Application Server as a desk top application and confirm Sage Exchange launches when adding or processing credit cards before running as a service.
    • Install Sage Exchange on workstation
    1.     Open www.SageExchange.com/Install 
    2.     Click Next to proceed to Sage End User License Agreement
    3.     Click Install 
    Note: It is recommended to create a domain account, with local admin permissions to run the Sage 100 ERP Advanced or Premium service.
    Related Resources


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    Chris Love
    Accounting Systems, Inc. (ASI)
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  • 5.  RE: SPS/Paya - "The credit card transaction request to Sage Exchange cannot be processed"

    Posted 05-06-2020 10:35
    I thought they changed the new Paya client to not install into the user profile (the way the old one did...).
    You might want to check on TLS 1.2 (required since mid-2018 for Paya).

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    Kevin Moyes
    Technical Systems Analyst
    Munjal White Consulting Co.
    Toronto ON
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  • 6.  RE: SPS/Paya - "The credit card transaction request to Sage Exchange cannot be processed"

    Posted 07-08-2020 20:24
    Moved thread from Urgent to Sage 100 Community.

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    Moira Goggin
    Executive Director
    90 Minds, Inc.
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