Is this Premium?
Error: "OI Access Failed"
Products
Sage 100
Description
Error: "OI Access Failed" when executing OITest.exe or Error: 200 when instatiating SY_Session.pvc via Business Objects Interface on a Sage 100 ERP Premium installation.
Cause
The SQL Server Native Client designated into the SOTA.INI and MASSQL.Settings file do not exist on the workstation.
Resolution
Edit the server's SOTA.INI and MASSQL.Settings file to match what driver is installed on the workstation client and on the server:
At the workstation, Click on the Windows Start button the Search or Run and type
ODBCAD32 and press ENTER.
Click on ODBCAD32.exe
At the ODBC Data Source Administrator screen click on Drivers
Note what SQL Server Native Client drivers are listed and close the screen
Repeat these steps on the server, again noting what SQL Server Native Client drivers are installed there.
Go to the server's MAS90\HOME\ directory and edit the MASSQL.Settings file:
Change the following line:
CONNECT='Driver={SQL Server Native Client 10.0}';
Enter the newest available SQL client used on both the server and the workstation.
Exit the file and save changes.
Go to the server's MAS90\Launcher directory and edit the SOTA.INI file:
Change the following line:
[MSSQL]
DRIVER=SQL Server Native Client 11.0
Enter the newest available SQL client used on both the server and the workstation.
Exit the file and save changes.
OI Test and Business Objects Interface should now run correctly.
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Doug Higgs
Assistant Technical Support / Building Maintenance Specialist
Midwest Commerce Solutions, Inc
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