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  • 1.  Issues from Providex to SQL upgrade in 2018/2019 with Payroll

    Posted 08-02-2019 10:47
    Edited by Michelle Forsey 08-02-2019 15:14
    Just as a heads up there is an issue with the conversion process when going from anything pre-2017 Providex to Premium 2018 or 2019 when payroll is installed. 

    We had a client upgrade and they went from having around 200 employees in Providex to 10 in SQL. Here was the find from Linda Rabey, She is publishing the KB Article today, so I will update as soon as I get it. 

    *Edit: Link to KB 

    Proceed with Caution! 
    *********************************

    Michelle,

     We found the problem today why the employees were being dropped and are working on a fix for it.  It has to do with the PR1 legacy file having larger data than intended in the TimeOff(1,2,3)AnnualLimitHours fields.  Since those fields were only meant to have masking of xxx.xx and they currently have 99999.99 in the field they wouldn't convert.  I don't have a target release date yet but when I do you will be the first to know.

    Thank you,

    Linda

    Linda Raby

    Sage 100 Product Mentor, Advisory

    Sage



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    Michelle Forsey
    Eide Bailly, Inc.
    801-456-5470
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  • 2.  RE: Issues from Providex to SQL upgrade in 2018/2019 with Payroll

    Posted 08-02-2019 10:58
    Great post - thank you for keeping us updated!

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    Wayne Schulz - Schulz Consulting - 860-516-8990
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  • 3.  RE: Issues from Providex to SQL upgrade in 2018/2019 with Payroll

    Posted 08-02-2019 11:05
    Yes!  Now if only Sage could learn to be proactive about announcing newly discovered bugs / issues...
    *dare to dream...*

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    Kevin Moyes
    Technical Systems Analyst
    Munjal White Consulting Co.
    Toronto ON
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  • 4.  RE: Issues from Providex to SQL upgrade in 2018/2019 with Payroll

    Posted 08-02-2019 11:17
    I don't think I can name one thing, aside from price hikes,  Sage has been proactive about.

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    Wayne Schulz - Schulz Consulting - 860-516-8990
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  • 5.  RE: Issues from Providex to SQL upgrade in 2018/2019 with Payroll

    Posted 08-14-2019 14:16
    Workaround has been posted to the KB, fix expected in Next Product Update:

    Description
    <content>

    Converting customer data from Sage 100 Standard 2019 to Sage 100 Premium 2019 fails to convert all employees and drops many employee records during conversion in sql.

    </content>

    Cause
    <content>

    Legacy PR1 file dictionary defines fields 17, 18, 19 (AnnualHourLimit1,2,or 3) length as 3.2 (999.00) yet Providex allows field lengths to be ignored in Pvx files so conversion to Standard/Advanced didn't error. SQL does not allow field lengths to be ignored so when we try to convert to Premium we get the write error and employee record is not saved in SQL.

    </content>

    Resolution
    <content>

    Under review in Engineering for a change to schema in future release.

    For now the work around is:
    1. In legacy, access each benefit record in P/R Setup, Benefit Schedule Maintenance
    2. Vacation / Sick / Personal
    3. Change the Hours/Year to no more than 999.99
    4. Apply Changes to all employees
    5. Save the records
    6. Remigrate and convert data.

    When Creating new Time Off code PR 2.x, hours/year = 999.99 maximum until the schema is corrected.

    </content>

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    Michelle Forsey
    Eide Bailly, Inc.
    801-456-5470
    ------------------------------