Sage 100

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  • 1.  Is Print Spooler on server or workstation used?

    Posted 07-01-2021 16:03

    "Does a normal Sage 100 user using the client on their laptop use the print spooler on the server or on their laptop?"  I was thinking 'server' for Advanced/Premium and 'workstation' for Standard, but wasn't sure.  This is related to a Cybersecurity Alert:  PrintNightmare, Critical Windows Print Spooler Vulnerability (06/30/2021 05:32 PM EDT)



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    Brett Zimmerman
    Net at Work
    Greater Boston Area
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  • 2.  RE: Is Print Spooler on server or workstation used?

    Posted 07-02-2021 07:02
    Nice catch. I could see more questions coming from IT. Hopefully shutting down or disabling a server print spoiler won’t impact Sage.

    More https://www.theverge.com/2021/7/2/22560435/microsoft-printnightmare-windows-print-spooler-service-vulnerability-exploit-0-day

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    Wayne Schulz - Schulz Consulting - 860-516-8990
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  • 3.  RE: Is Print Spooler on server or workstation used?

    Posted 07-02-2021 08:16
    I believe the job spools on the same computer that processes the print job.  Crystal reports always processes the job at the workstation that initiated the print job, so it would seem the print job should always spool at the workstation for Standard, Advanced, or Premium.

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    Doug Higgs
    Midwest Commerce Solutions, Inc
    (312) 315-0960
    Assistant to the Traveling Secretary
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  • 4.  RE: Is Print Spooler on server or workstation used?

    Posted 07-02-2021 12:01
    Thanks!  Some other info I obtained:
    • "I believe it depends more on where the print driver resides…i.e., network or local printer."
    • "If the printer is installed locally, then it's going to use the local spooler.  If they are printing via RDP, server spooler is involved.  If the printer is shared via Windows sharing, it uses the server spooler (I'm pretty sure).  If it's shared via IP on the network, I believe that will be local spooler."


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    Brett Zimmerman
    Net at Work
    Greater Boston Area
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  • 5.  RE: Is Print Spooler on server or workstation used?

    Posted 07-02-2021 12:04
    Have you found anything which indicates the IT department needs to pay special attention to Sage's needs with reference to potentially shutting down any print spoolers? Or does Sage use the print spooler in pretty much the same way as any other network application and therefore doesn't require special consideration?

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    Wayne Schulz - Schulz Consulting - 860-516-8990
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  • 6.  RE: Is Print Spooler on server or workstation used?

    Posted 07-02-2021 12:09
    Even if it is a network printer the appropriate driver gets installed on the workstation.

    However, you may be correct about spooling where the printer is installed, but I am not sure.  If this is correct, then no wonder users complain about Sage 100 being slow.  Crystal reports always renders the print job at the workstation. If the printer is installed on the server and the spooling is done on the server, then that means data needs to first transmit to the workstation, be assembled for printing, then be transmitted back to the server for spooling.  That's a lot of network traffic.  It wouldn't technically be Sage 100 that's slow, it's the lack of available bandwidth.

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    Doug Higgs
    Midwest Commerce Solutions, Inc
    (312) 315-0960
    Assistant to the Traveling Secretary
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  • 7.  RE: Is Print Spooler on server or workstation used?

    Posted 07-07-2021 15:15
    @Wayne Schulz, I'm not sure (to both your questions), but obviously Microsoft released an Update today. ​​

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    Brett Zimmerman
    Net at Work
    Greater Boston Area
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  • 8.  RE: Is Print Spooler on server or workstation used?

    Posted 07-09-2021 11:43
    Edited by Brett Zimmerman 07-09-2021 11:58
    Sage has published the below KB Article, including, “All of our Sage software products depend on the print spooler being enabled to some extent”.  Thanks, @Wayne Schulz.

    Sage software products may fail due to a disabled Windows Print Spooler

    Created on 07-02-2021 | Last modified on 07-09-2021

    Summary


    A critical vulnerability was discovered in the Windows Print Spooler

    The Cybersecurity & Infrastructure Security Agency (CISA) recommends the print spooler be disabled until patched: https://us-cert.cisa.gov/ncas/current-activity/2021/06/30/printnightmare-critical-windows-print-spooler-vulnerability.

    All of our Sage software products depend on the print spooler being enabled to some extent – for example, 300CRE will not run, print, or post – Sage 100 Contractor will not be able to print to PDF, RTF, and normal printer drivers with the print spooler disabled.

    Hosting provider group policies were likely updated on July 2, 2021. Anyone running Sage software products on a hosting provider will see Sage software products fail.

    Disclaimer

    Operating System Warning
    This solution requires advanced knowledge of your computer's operating system. Contact your system administrator for assistance. Modifying your Windows Registry incorrectly can severely affect system operations. Sage is not responsible for operation issues caused by incorrectly modifying your Windows Registry. Always create a backup of your data before proceeding with advanced solutions.

    Cause


    The Windows Print Spooler Service has been disabled via a Group Policy Object.

    Resolution


    Customers who encounter this issue should consult with their qualified IT support professional.

    Keywords

    Can't print, won't run, printer failed, print spooler won't start, cannot start service, pdf, rtf, printer driver, hourglass, freezes, program won't start, launch, run, Printnightmare, CVE-2021-34527, Print Nightmare, SSH, Sage service host,

    Need help?
    ​​

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    Brett Zimmerman
    Net at Work
    Greater Boston Area
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