Sage 100

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  • 1.  Error: "XYYYYYY ZZZZZZ is not on file." when drilling down on Transaction Zoom on Sage 100 2021

    Posted 09-21-2021 15:50

    Summary

    <content>

    Error: "XYYYYYY ZZZZZZ is not on file." when drilling down on Transaction Zoom in GL Account Maintenance or GL Account Inquiry on Sage 100 2021 where X=Bank YYYYYY=CheckNumber and ZZZZZZ=SequenceNo

    </content>

    Cause

    <content>

    Migration from 2018 to 2021 did not expand the DocumentNo$ field which is the bank code and check number.

    </content>

    Resolution

    <content>

    Sage Engineering is currently reviewing this issue.

    Workaround:

    Using Data File Display and Maintenance, manually enter the leading zeros after the check code in the GL_DetailPosting, DocumentNo$ field. Consultant can alternately sit on hands and hope that their customer does drill down into more than one transaction as there doesn't appear to be a way to fix all transactions at this time. Alternatively, suggest upgrade to Sage Intacct which we would fix immediately if we ever found an issue such as this.

    </content>


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    Wayne Schulz - Schulz Consulting - 860-516-8990
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  • 2.  RE: Error: "XYYYYYY ZZZZZZ is not on file." when drilling down on Transaction Zoom on Sage 100 2021

    Posted 09-21-2021 16:17
    @Wayne Schulz - Are you having a rough day or are you just hopping on the sarcasm wagon??​

    ------------------------------
    Jeff Schwenk
    FORMER 90M Board Member -140,000,000 is a TERRIBLE thing to waste!!!
    Bottomline Software, Inc.
    Waynesboro VA
    540-221-4444
    ------------------------------



  • 3.  RE: Error: "XYYYYYY ZZZZZZ is not on file." when drilling down on Transaction Zoom on Sage 100 2021

    Posted 09-21-2021 16:49
    This is crazy that almost 6 months and two product updates after release that these types of bugs are being found. Maybe people are very slow to upgrade to 2021.

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    Wayne Schulz - Schulz Consulting - 860-516-8990
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  • 4.  RE: Error: "XYYYYYY ZZZZZZ is not on file." when drilling down on Transaction Zoom on Sage 100 2021

    Posted 09-21-2021 16:47
    Edited by Wayne Schulz 09-21-2021 16:51
      |   view attached
    Steps to resolve: 

    From what I can tell -- and as noted in the KB -- there is presently ( 9/20/21 ) no way to fix all the data elements. This is a fix for a single record. In my customer's case, they receive the error on other records as well when they try to drill down to the check info from GL Inquiry - Transactions.

    1. If you have a large volume of data - it may take a while to search out the key. Use the attached Crystal Report and before you run it set the document number to equal the first part of the error --- in the above example AW00616 ( make sure you edit the attached report and put in your own select value for DocumentNo ) 

    2. DFDM GL_DetailPosting.M4t

    In my example, I had to expand AW00616 to AW000000616 ( 1 char bank code plus 10 char check number with leading zeroes )

    BEFORE



    AFTER



    I'm not really sure why the data dictionary specifies 20 characters for the DocumentNo field as I wound up using 11 - which was one char for the bank code followed by 10 for the check number. This was on a v2021 which I had migrated from 2016. The KB specifies that the issue was noted as arising on a migration from 2018 but I suspect it may happen on just about any version.







    ------------------------------
    Wayne Schulz - Schulz Consulting - 860-516-8990
    ------------------------------

    Attachment(s)

    rpt
    DocumentNo.rpt   90 KB 1 version


  • 5.  RE: Error: "XYYYYYY ZZZZZZ is not on file." when drilling down on Transaction Zoom on Sage 100 2021

    Posted 09-21-2021 17:46
    So it appears that the issue is specific to a v2018 migration to v2021.  TG I have only done one of these and they haven't called yet.  Hopefully, they will have it fixed when my v2016 client gives the go ahead for v2021.

    ------------------------------
    Jeff Schwenk
    FORMER 90M Board Member -140,000,000 is a TERRIBLE thing to waste!!!
    Bottomline Software, Inc.
    Waynesboro VA
    540-221-4444
    ------------------------------



  • 6.  RE: Error: "XYYYYYY ZZZZZZ is not on file." when drilling down on Transaction Zoom on Sage 100 2021

    Posted 09-21-2021 17:47
    This appeared on a 2016 to 2021 migration for me.

    ---------------------------------
    Wayne Schulz - Schulz Consulting - 860-516-8990
    ---------------------------------





  • 7.  RE: Error: "XYYYYYY ZZZZZZ is not on file." when drilling down on Transaction Zoom on Sage 100 2021

    Posted 09-21-2021 17:54
    Big Sigh...  So bad migration code with 2018?  Perplexing.

    ------------------------------
    Jeff Schwenk
    FORMER 90M Board Member -140,000,000 is a TERRIBLE thing to waste!!!
    Bottomline Software, Inc.
    Waynesboro VA
    540-221-4444
    ------------------------------



  • 8.  RE: Error: "XYYYYYY ZZZZZZ is not on file." when drilling down on Transaction Zoom on Sage 100 2021

    Posted 09-21-2021 18:15
    I tried to duplicate the issue as the customer went live in 2021 about a week before Sage posted the KB. Hopefully they will have a fix for existing data.

    ---------------------------------
    Wayne Schulz - Schulz Consulting - 860-516-8990
    ---------------------------------





  • 9.  RE: Error: "XYYYYYY ZZZZZZ is not on file." when drilling down on Transaction Zoom on Sage 100 2021

    Posted 10-06-2021 11:09
    As of 10/6/2021, there is a utility to fix this issue 


    There does not yet appear to be a fix for conversion to 2021 which stops this issue. However, the workaround, for the time being, is to run the utility after you convert to 2021.


    ------------------------------
    Wayne Schulz
    Schulz Consulting
    860-516-8990
    ------------------------------